Upstream DNS issues
Incident Report for Rollbar
Postmortem

We've posted the postmortem for this incident on our blog:

https://rollbar.com/blog/dns-ddos-postmortem/

Posted Oct 25, 2016 - 19:03 PDT

Resolved
This issue should now be resolved. If you are still seeing any problems reaching api.rollbar.com or rollbar.com, please reach us via support@rollbar.com.

Our primary DNS provider (that had the outage starting this morning) has reported that the issue is resolved on their side. This should mean that all clients are able to resolve rollbar.com and api.rollbar.com, regardless of whether the nameserver change has propagated.

We'll be doing a full postmortem on this event early next week and will share more details about the issue, impact, and future steps then.
Posted Oct 21, 2016 - 15:24 PDT
Update
Nameserver propagation update: Google's DNS servers (8.8.8.8 and 8.8.4.4) now see our new DNS provider. If you are still having trouble accessing Rollbar, try setting your DNS servers to 8.8.8.8 and 8.8.4.4 .
Posted Oct 21, 2016 - 13:49 PDT
Update
We've started migration to another DNS provider (currently waiting for the nameserver change to propogate). In the meantime, you can reach Rollbar by adding the following to your /etc/hosts :

192.155.197.230 api.rollbar.com
50.23.231.133 rollbar.com

We'll provide further updates here, on Twitter when possible (Twitter is affected by the same issue), and on our Facebook page: https://www.facebook.com/rollbarinc/
Posted Oct 21, 2016 - 11:07 PDT
Monitoring
A DDoS attack on an upstream DNS provider is causing intermittent name resolution errors for both our web UI and API tier. We're monitoring the situation and attempting to mitigate the issue.
Posted Oct 21, 2016 - 09:23 PDT