Web app degraded performance
Resolved·Degraded performance

We've implemented a fix and the system is performing normally again.

Mon, Jul 14, 2025, 07:34 PM
(1 month ago)
·
Affected components
Updates

Resolved

We've implemented a fix and the system is performing normally again.

Mon, Jul 14, 2025, 07:34 PM

Investigating

We've identified an issue causing degraded performance in the web app including Item List. We're working to resolve the issue.

Mon, Jul 14, 2025, 07:02 PM(31 minutes earlier)