Resolved
The performance issue has been resolved. We will be rolling out several additional optimizations soon to ensure better service going forward. Thanks for your patience!
Monitoring
Performance has improved; we've identified several areas for improvement, and we're continuing to monitor.
Investigating
We’re experiencing slow performance on the web app. We’re investigating short-term fixes. We don’t have an ETA for resolution available at this time; however, we do expect performance to improve later in the day as load decreases.