Elevated API error rate
Resolved·Degraded performance

# Incident Report

## Summary of the Incident and Impact

From 2025-09-03 05:35 PT until approximately 14:03 PT, the Rollbar ingestion API) served a high rate of 502 errors because a particular traffic pattern exhausted the resources available to other traffic. The range of 502 errors ranged from 30% to 60% of requests during the incident. Once the root cause was identified and mitigated, error levels returned to below 0.01%.

The Web App and Processing tiers were not affected.

[1] POST requests to api.rollbar.com/api/1/item , api.rollbar.com/api/1/item_batch/ , api.rollbar.com/api/1/items/ 

## Follow-Up Actions

We've identified follow-up actions to mitigate going forward 1) the length of similar incidents (completed), 2) the possibility of similar incidents (planned).

Tue, Sep 9, 2025, 11:01 PM
(6 days ago)
·
Affected components
API Tier (api.rollbar.com)
Updates

Resolved

# Incident Report

## Summary of the Incident and Impact

From 2025-09-03 05:35 PT until approximately 14:03 PT, the Rollbar ingestion API) served a high rate of 502 errors because a particular traffic pattern exhausted the resources available to other traffic. The range of 502 errors ranged from 30% to 60% of requests during the incident. Once the root cause was identified and mitigated, error levels returned to below 0.01%.

The Web App and Processing tiers were not affected.

[1] POST requests to api.rollbar.com/api/1/item , api.rollbar.com/api/1/item_batch/ , api.rollbar.com/api/1/items/ 

## Follow-Up Actions

We've identified follow-up actions to mitigate going forward 1) the length of similar incidents (completed), 2) the possibility of similar incidents (planned).

Tue, Sep 9, 2025, 11:01 PM

Resolved

This incident has been resolved. We'll publish a postmortem in the coming days.

Wed, Sep 3, 2025, 09:03 PM(6 days earlier)

Identified

We've implemented a fix and are monitoring the results.

Wed, Sep 3, 2025, 08:42 PM(21 minutes earlier)

Identified

We're continuing to work on a fix for this issue.

Wed, Sep 3, 2025, 06:28 PM(2 hours earlier)

Identified

We've identified the likely root cause, and are working on implementing a fix.

Wed, Sep 3, 2025, 05:13 PM(1 hour earlier)

Investigating

We're investigating an issue with elevated error rates on api.rollbar.com affecting occurrence ingestion.

Wed, Sep 3, 2025, 04:53 PM(19 minutes earlier)