Resolved
The update took a lot longer due to the mass of data involved. However it is now complete and we apologize for any impact this made.
Investigating
We have been experiencing an issue with one of our databases, so we need to apply some emergency remediation to recover. We apologize for the short notice around this and will aim to keep any impact to a minimum while this takes place.