Items and Item Detail pages inaccessible for some users
Incident Report for Rollbar
Postmortem

On Monday, July 15th from 11:30 AM (All times PDT) until 2:30 PM our Items List and Item Detail pages were down for users who were integrated with Bitbucket.

The reason for the outage were some complications migrating Bitbucket APIs from v1 to v2. The way we were storing new tokens was mishandled, but shortly resolved.

We've resolved a process of ensuring this doesn't happen again. We know that you rely on Rollbar and we’re sorry to let you down. If you have any questions, please don't hesitate to contact us at support@rollbar.com.

Posted Jul 18, 2019 - 10:26 PDT

Resolved
We have not seen any new occurrences of this error.
Posted Jul 15, 2019 - 18:22 PDT
Monitoring
We've identified the issue, deployed a fix, and are monitoring new errors.
Posted Jul 15, 2019 - 16:13 PDT
Identified
We're investigating an issue where the Items, Item Detail, and SCM Settings pages 500 for some users. We've identified the cause and are working on a fix.
Posted Jul 15, 2019 - 14:26 PDT
This incident affected: Web App (rollbar.com).