Web app degraded performance

Incident Report for Rollbar

Resolved

We've implemented a fix and the system is performing normally again.
Posted Jul 14, 2025 - 12:34 PDT

Investigating

We've identified an issue causing degraded performance in the web app including Item List. We're working to resolve the issue.
Posted Jul 14, 2025 - 12:02 PDT
This incident affected: Web App (rollbar.com).